Crashing my Visual Studio

Dec 11, 2012 at 6:24 AM

I followed the steps here to add extensions since you didn't have time to add in a configurable file/option: http://nshader.codeplex.com/discussions/394745

 

Because I added some extensions to that pkgdef, deleted the Cache tree, and now what I have is a crashing solution (or rather in a permanent loop) if the associated file is opened.

I removed those extensions in pkgdef, but your plugin is still crashing my Visual Studio. Tried an uninstall, no avail, reinstall, same thing.

I only omitted this part and was wondering is it safe to delete the whole tree (and it subtrees) of

HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0_Config

?

 

I would appreciate it if you can post a FULL manual uninstall of your plugin. I have multiple customised settings of plugins and do not wish to do a reinstall of Visual Studio. I am using 1.3 of NShader.

Coordinator
Dec 11, 2012 at 8:05 AM

I don't understand this "tried an uninstall, no avail, reinstall". What is "no avail"?

NShader in itself should work well, but VS extensions can conflicts between them, so when you say that this is NShader that is crashing your solution, this could be actually another extension that is interfering with NShader. The only thing I know is that NShader is a pretty simple extension that doesn't mess VS or perform any advanced trick with VS, so it is unlikely to crash. I wouldn't say the same for NSight, ReSharper, VisualAssist...etc. that are complex beast touching several parts of VS and often interfering with other extensions. So if you have a crash, it is not 100% sure that this is NShader, but could be another plugin or a combination of them.

The registry key "10.0_Config" is rebuilt by VS201x when you launch it (unless nothing changed), so you can safely remote it. It is basically rebuilt from 10.0 and all pkgdefs around the disks.

Also ,uninstalling NShader is just a matter of going to the extension manager and press uninstall button, If the button is disabled, you just have to run VS201x in administrator mode.

Dec 11, 2012 at 4:26 PM

Oh I mean "to no avail", sorry if I was unclear on that.

Yea somehow VisualAssistX was causing it to hang.

 

However one issue still remains. So I delete that tree, disabled VAX and relaunched my project. No hanging. I opened up my .vert file, and it no longers show anything at all for that file. Pure blueness. No text, nothing, just a tab as usual. Any idea why that happened and how to fix it?

Coordinator
Dec 12, 2012 at 1:46 PM

Sorry, never had this issue before, so I don't know what is the source of the problem.  I have already added some extensions like this in NShader without getting any problem, so It is more likely a configuration problem in your VS.