Visual Studio 2012 RC - Dark colour theme issue

Jul 19, 2012 at 10:20 PM

A very nice syntax highlighter but unfortunately it's incompatible with the darker colour scheme that Visual Studio 2012 offers (Tools -> Options -> Color theme). The colours applied make some text very difficult to see on a black background (mostly the darker blue you use).

Would it be possible to offer support for this configuration?

Coordinator
Jul 20, 2012 at 2:05 AM

You can change the colors in the VS Options/Font and colors, look at all Shader Language entries. Unfortunately, it will not support switching between themes (the color changes is done for all theme). Don't have currently time to fix this behavior.

Jul 20, 2012 at 10:44 AM

Thanks, I didn't realise there were Font/Colour settings for the Shader Language entries.

Great work on the plugin!

Aug 30, 2012 at 8:42 PM

Any idea of how to fix this issue on VS2010? In Tools>Options>Environment>Fonts and Colors I can change some colors, but I can't seem to find the specific colors Shader Languages.

Coordinator
Aug 30, 2012 at 11:11 PM
cmdalbem wrote:

Any idea of how to fix this issue on VS2010? In Tools>Options>Environment>Fonts and Colors I can change some colors, but I can't seem to find the specific colors Shader Languages.

Have you tried to remove the font cache from the registry at it is described on the download page for 1.3 release?

Sep 3, 2012 at 3:00 PM
Edited Sep 3, 2012 at 3:00 PM
alexandre_mutel wrote:
cmdalbem wrote:

Any idea of how to fix this issue on VS2010? In Tools>Options>Environment>Fonts and Colors I can change some colors, but I can't seem to find the specific colors Shader Languages.

Have you tried to remove the font cache from the registry at it is described on the download page for 1.3 release?

No, I didn't, because I thought it was only for whose no highlighting works at all. But I tried it now because you said to do so, and opening VS2010 again and loading my dark color theme again has brought the same issue again.

If only I could manually edit only the dark blue colors...

Oct 24, 2012 at 12:38 PM

I'm in the same situation as cmdalbem. I wish I could use this with the dark color theme. Everytime I work on shaders for a longer while I end up having to convert back to a light theme.. mainly because the the dark blue/red is hard to read. Wish I could just edit them manually, or that there was a "dark version" of the nshader.. maybe based on the immensely popular dark theme SonOfObsidian :)

Feb 7, 2013 at 3:08 AM
I did this a while ago. I can only confirm it works for vs2010.

http://studiostyl.es/schemes/son-of-obsidian-resharper-nshader
Jun 4, 2013 at 5:16 AM
Hello, I followed all of the instructions on the home page, including deleting the registry keys and deleting those lines out of the file, but I still don't get "shader" (or all shaders or shader colours or any variance thereof) as an option in Fonts and Colors.

I'm using Windows 8 64-bit and VS 2012.

P.S. Thanks for the awesome plugin! :D:D:D
Jun 4, 2013 at 5:20 AM
Never mind. I was looking in the wrong section :P.

The Shader Language colours are in the Display Items list, not in the Show settings for: dropdown.

Again, thank you for this plugin, it is awesome :)
Sep 11, 2013 at 2:21 AM
This theme is great but it is not up to date with the latest setting strings of NShader.

To fix it, simply replace :
<Item Name="Script Comment" Foreground="0x007B7466" Background="0x02000000" BoldFont="No"/>
<Item Name="Script Identifier" Foreground="0x02000000" Background="0x02000000" BoldFont="No"/>
<Item Name="Script Keyword" Foreground="0x0063C793" Background="0x02000000" BoldFont="No"/>
<Item Name="Script Number" Foreground="0x0022CDFF" Background="0x02000000" BoldFont="No"/>
<Item Name="Script Operator" Foreground="0x02000000" Background="0x02000000" BoldFont="No"/>
<Item Name="Script String" Foreground="0x000076EC" Background="0x02000000" BoldFont="No"/>
With :
<Item Name="Shader Language - Comment" Foreground="0x007B7466" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - Identifier" Foreground="0x02000000" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - Intrinsic" Foreground="0xc763c5" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - Keyword" Foreground="0x0063C793" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - Number" Foreground="0x0022CDFF" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - Preprocessor" Foreground="0x00BD82A0" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - Special" Foreground="0x006385c7" Background="0x02000000" BoldFont="No"/>
<Item Name="Shader Language - String" Foreground="0x000076EC" Background="0x02000000" BoldFont="No"/>