Fixed problems on Windows XP 64-bit (VS 2010 Professional)

Jan 28, 2011 at 10:47 AM


First thanks for the good work!

After some trial and error I got it working on the configuration specified in the headline. I saw from the previous discussions that some people seems to have similar problems, so I though I post here how got it running on my machine.  Maybe there is a better way to do it but that's how I fixed my problems:

After installing the precompiled version i tried to load a .frag file in VS and got an error message that the NShader package did not load correctly and it showed and empty tab for the source file and VS was freezing.

So I downloaded the source and compiled it by myself for x86 (after installing the Visual Studio SDK) which gave the same problem.

I followed the instructions and enabled the /log option and the ActivityLog.xml showed that the path where VS tried to locate NShader was wrong. I figured that the %localappdata% is not defined in WindowsXP (VS defines it but that doesn't seems to be set when the macro is expanded) which is used in NShader.pkgdef. So I tried to replace it through a path based on %homepath% which seemed to solve the issue to locate the right folder where NShader was installed but this time the path to the NSHader.DLL was wrong for some reason.

So following the instructions here:

I added the line


to the source.extension.vsixmanifest file which will install NShader in a different directory available to all users on the system. I updated the new path in NShader.pkgdef like this:
"CodeBase"="%programfiles(x86)%\\Microsoft Visual Studio 10.0\\Common7\\IDE\\Extensions\\Alexandre Mutel\\NShader\\1.1\\NShader.dll"
and it finally worked.

Hope this helps somebody.

Thanks again Alexandre.

Jan 28, 2011 at 1:08 PM

Cool, thanks for debugging this. I was looking for a location but didn't think about the programfiles one. I will integrate this in the next small release.

Jan 29, 2011 at 2:45 PM

It should be fixed in 1.2