Not working under vs2010 pro

Aug 13, 2010 at 4:44 PM

After installing a plugin i received error with "unable to load" message.

Now i cant open anyproject.

Aug 15, 2010 at 10:25 AM

Never had this problem before, It's working fine here under VS2010 PRo, so I suspect another issue on your VS2010 config.... Is NShader the only plugin installed on your VS2010? Currently, NShader is only loaded when a fx file is opened.

Sep 17, 2010 at 10:14 AM


i also get the unable to load message. the funny thing is it works with local profiles but when i log into a remote profile (domain) the plugin does not work.

i tried it on a clean windows 7 x64 with visual studio 2010 utlimate using also a clean new profile. this is extremely frustrating. i looked up the source code to see how the plugin is loaded and i found no other plugin which does it this complicated. is there maybe another way to load the plugin or give more detailed error messages on whats going wrong?

i really like this plugin and really need it. is spend the last day trying your precompiled version and what i could figure out on your source to build other versions, but none worked. all other plugins i tried work perfectly just yours does not.



Sep 17, 2010 at 12:29 PM

ok found the problem:

%LOCALAPPDATA%  is not defined on remote profiles!

i exchanged it with %TEMP%\\..\\  in the pfgdef file. then everything works as expected.

i made some changes to support glsl 4.1 core profile.



Sep 17, 2010 at 1:29 PM

Oh, thanks, this is indeed a bug, but I wouldn't have been able to reproduce it without a remote profile.

I'lll check what can be done in next version